aboutsummaryrefslogtreecommitdiff
path: root/graphics/imageindex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/imageindex/Makefile')
-rw-r--r--graphics/imageindex/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/imageindex/Makefile b/graphics/imageindex/Makefile
index 5605b6c8c403..6ff7a64872db 100644
--- a/graphics/imageindex/Makefile
+++ b/graphics/imageindex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= imageindex
-PORTVERSION= 1.0.7
+PORTVERSION= 1.0.9
CATEGORIES= graphics
MASTER_SITES= http://www.edwinh.org/imageindex/release/ \
http://www.reynoldsnet.org/imageindex/release/
@@ -20,16 +20,19 @@ RUN_DEPENDS= \
${SITE_PERL}/Image/Info.pm:${PORTSDIR}/graphics/p5-Image-Info
USE_REINPLACE= yes
+USE_PERL5_RUN= yes
+MAKE_ARGS+= PERLPATH=${PERL}
+
+PLIST_FILES= bin/imageindex bin/autocaption %%DOCSDIR%%/README
+PLIST_DIRS= %%DOCSDIR%%
MAN1= imageindex.1
post-patch:
${REINPLACE_CMD} -e 's|share/man|man| ;' ${WRKSRC}/Makefile
-.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
.include <bsd.port.mk>