aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/imlib2/Makefile')
-rw-r--r--graphics/imlib2/Makefile76
1 files changed, 59 insertions, 17 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index 2104e4e9a2cb..14032312beca 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -6,27 +6,31 @@
#
PORTNAME= imlib2
-PORTVERSION= 1.2.2.001
-PORTREVISION= 1
+PORTVERSION= 20060926
+PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= graphics
-MASTER_SITES= http://enlightenment.freedesktop.org/files/
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
-MAINTAINER= vanilla@FreeBSD.org
+MAINTAINER= stas@FreeBSD.org
COMMENT= The next generation graphic library for enlightenment package
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- ungif.5:${PORTSDIR}/graphics/libungif \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- id3tag.0:${PORTSDIR}/audio/libid3tag \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
-USE_AUTOTOOLS= autoconf:259 libltdl:15 libtool:15
-USE_GNOME= gnomehack pkgconfig gnometarget
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib"
+USE_BZIP2= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
USE_LDCONFIG= yes
+OPTIONS= JPEG "Enable jpeg image support" on \
+ PNG "Enable png image support" on \
+ TIFF "Enable tiff image support" on \
+ GIF "Enable GIF image support" on \
+ ID3 "Enable IDv3 tags support" on \
+ X11 "Enable X11 support" on
+
.include <bsd.port.pre.mk>
.if defined(WITH_MMX) && (${ARCH} == "i386")
@@ -46,12 +50,50 @@ USE_XLIB= yes
PLIST_SUB= X11=""
.endif
+.if !defined(WITHOUT_JPEG)
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+PLIST_SUB+= JPEG=""
+.else
+CONFIGURE_ARGS+= --without-jpeg
+PLIST_SUB+= JPEG="@comment "
+.endif
+
+.if !defined(WITHOUT_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+PLIST_SUB+= PNG=""
+.else
+CONFIGURE_ARGS+= --without-png
+PLIST_SUB+= PNG="@comment "
+.endif
+
+.if !defined(WITHOUT_TIFF)
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+PLIST_SUB+= TIFF=""
+.else
+CONFIGURE_ARGS+= --without-tiff
+PLIST_SUB+= TIFF="@comment "
+.endif
+
+.if !defined(WITHOUT_GIF)
+LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
+PLIST_SUB+= GIF=""
+.else
+CONFIGURE_ARGS+= --without-gif
+PLIST_SUB+= GIF="@comment "
+.endif
+
+.if !defined(WITHOUT_ID3)
+LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
+PLIST_SUB+= ID3=""
+.else
+CONFIGURE_ARGS+= --without-id3
+PLIST_SUB+= ID3="@comment "
+.endif
+
post-patch:
+.if ${OSVERSION} < 503000
@${REINPLACE_CMD} -e \
's|round|rint|g' ${WRKSRC}/src/lib/color_helpers.c
-
-# Kludge to keep it from touching Makefile.in files (configure.in is newer)
-post-configure:
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${TOUCH}
+.endif
.include <bsd.port.post.mk>