aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib2
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/imlib2')
-rw-r--r--graphics/imlib2/Makefile2
-rw-r--r--graphics/imlib2/files/patch-loader_png.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index 24055314dc34..8187b01b9562 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imlib2
PORTVERSION= 1.4.1.000
-PORTREVISION= 8
+PORTREVISION= 9
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
diff --git a/graphics/imlib2/files/patch-loader_png.c b/graphics/imlib2/files/patch-loader_png.c
index 5444c6260bad..ce76ad89d42e 100644
--- a/graphics/imlib2/files/patch-loader_png.c
+++ b/graphics/imlib2/files/patch-loader_png.c
@@ -5,7 +5,7 @@
/* if we haven't read the header before, set the header data */
fread(buf, 1, PNG_BYTES_TO_CHECK, f);
- if (!png_check_sig(buf, PNG_BYTES_TO_CHECK))
-+ if (png_check_sig(buf, 0, PNG_BYTES_TO_CHECK) != 0)
++ if (png_sig_cmp(buf, 0, PNG_BYTES_TO_CHECK))
{
fclose(f);
return 0;