aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib2_loaders/files/patch-configure
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/imlib2_loaders/files/patch-configure')
-rw-r--r--graphics/imlib2_loaders/files/patch-configure96
1 files changed, 96 insertions, 0 deletions
diff --git a/graphics/imlib2_loaders/files/patch-configure b/graphics/imlib2_loaders/files/patch-configure
new file mode 100644
index 000000000000..c8e012872602
--- /dev/null
+++ b/graphics/imlib2_loaders/files/patch-configure
@@ -0,0 +1,96 @@
+--- configure.orig Fri Sep 21 13:39:55 2001
++++ configure Sun Oct 7 18:56:43 2001
+@@ -888,16 +888,6 @@
+ fi
+
+
+- case "$enable_ltdl_convenience" in
+- no) { echo "configure: error: this package needs a convenience libltdl" 1>&2; exit 1; } ;;
+- "") enable_ltdl_convenience=yes
+- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
+- esac
+- LIBLTDL='${top_builddir}/''libltdl'/libltdlc.la
+- INCLTDL='-I${top_srcdir}/''libltdl'
+-
+-subdirs="libltdl"
+-
+
+ # Extract the first word of "gcc", so it can be a program name with args.
+ set dummy gcc; ac_word=$2
+@@ -3429,76 +3419,6 @@
+ esac
+ done
+
+- for ac_config_dir in libltdl; do
+-
+- # Do not complain, so a configure script can configure whichever
+- # parts of a large source tree are present.
+- if test ! -d $srcdir/$ac_config_dir; then
+- continue
+- fi
+-
+- echo configuring in $ac_config_dir
+-
+- case "$srcdir" in
+- .) ;;
+- *)
+- if test -d ./$ac_config_dir || mkdir ./$ac_config_dir; then :;
+- else
+- { echo "configure: error: can not create `pwd`/$ac_config_dir" 1>&2; exit 1; }
+- fi
+- ;;
+- esac
+-
+- ac_popdir=`pwd`
+- cd $ac_config_dir
+-
+- # A "../" for each directory in /$ac_config_dir.
+- ac_dots=`echo $ac_config_dir|sed -e 's%^\./%%' -e 's%[^/]$%&/%' -e 's%[^/]*/%../%g'`
+-
+- case "$srcdir" in
+- .) # No --srcdir option. We are building in place.
+- ac_sub_srcdir=$srcdir ;;
+- /*) # Absolute path.
+- ac_sub_srcdir=$srcdir/$ac_config_dir ;;
+- *) # Relative path.
+- ac_sub_srcdir=$ac_dots$srcdir/$ac_config_dir ;;
+- esac
+-
+- # Check for guested configure; otherwise get Cygnus style configure.
+- if test -f $ac_sub_srcdir/configure; then
+- ac_sub_configure=$ac_sub_srcdir/configure
+- elif test -f $ac_sub_srcdir/configure.in; then
+- ac_sub_configure=$ac_configure
+- else
+- echo "configure: warning: no configuration information is in $ac_config_dir" 1>&2
+- ac_sub_configure=
+- fi
+-
+- # The recursion is here.
+- if test -n "$ac_sub_configure"; then
+-
+- # Make the cache file name correct relative to the subdirectory.
+- case "$cache_file" in
+- /*) ac_sub_cache_file=$cache_file ;;
+- *) # Relative path.
+- ac_sub_cache_file="$ac_dots$cache_file" ;;
+- esac
+- case "$ac_given_INSTALL" in
+- [/$]*) INSTALL="$ac_given_INSTALL" ;;
+- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
+- esac
+-
+- echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
+- # The eval makes quoting arguments work.
+- if eval ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir
+- then :
+- else
+- { echo "configure: error: $ac_sub_configure failed for $ac_config_dir" 1>&2; exit 1; }
+- fi
+- fi
+-
+- cd $ac_popdir
+- done
+ fi
+
+