aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/imlib')
-rw-r--r--graphics/imlib/Makefile6
-rw-r--r--graphics/imlib/files/patch-io-png.c46
-rw-r--r--graphics/imlib/files/patch-load.c17
-rw-r--r--graphics/imlib/files/patch-save.c11
-rw-r--r--graphics/imlib/files/patch-utils.c19
5 files changed, 96 insertions, 3 deletions
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index 45f07869cc5e..45ae9074f4ae 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= imlib
PORTVERSION= 1.9.15
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
@@ -16,7 +16,7 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= A graphic library for enlightenment package
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
gif.5:${PORTSDIR}/graphics/giflib
@@ -29,7 +29,7 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib --disable-modules
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
MAN1= imlib-config.1 imlib_config.1
diff --git a/graphics/imlib/files/patch-io-png.c b/graphics/imlib/files/patch-io-png.c
new file mode 100644
index 000000000000..c4f315a15f4d
--- /dev/null
+++ b/graphics/imlib/files/patch-io-png.c
@@ -0,0 +1,46 @@
+--- gdk_imlib/io-png.c.orig 2002-03-04 18:06:29.000000000 +0100
++++ gdk_imlib/io-png.c 2012-04-24 23:11:43.000000000 +0200
+@@ -5,6 +5,7 @@
+
+ #ifdef HAVE_LIBPNG
+ #include <png.h>
++#include <pngpriv.h>
+
+ unsigned char *
+ loader_png (FILE * f, int *w, int *h, int *t)
+@@ -40,7 +41,7 @@
+ return NULL;
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ return NULL;
+@@ -275,7 +276,7 @@
+ return NULL;
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ return NULL;
+@@ -440,7 +441,7 @@
+ return NULL;
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ return NULL;
+@@ -635,7 +636,7 @@
+ png_destroy_write_struct(&png_ptr, (png_infopp) NULL);
+ return 0;
+ }
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ fclose(f);
+ png_destroy_write_struct(&png_ptr, (png_infopp) NULL);
diff --git a/graphics/imlib/files/patch-load.c b/graphics/imlib/files/patch-load.c
index a51987eb63ef..471406402710 100644
--- a/graphics/imlib/files/patch-load.c
+++ b/graphics/imlib/files/patch-load.c
@@ -1,5 +1,22 @@
--- Imlib/load.c.orig 2004-09-21 02:23:20.000000000 +0200
+++ Imlib/load.c 2010-03-28 16:23:13.000000000 +0200
+@@ -170,6 +176,7 @@
+ #endif /* HAVE_LIBJPEG */
+
+ #ifdef HAVE_LIBPNG
++#include <pngpriv.h>
+ unsigned char *
+ _LoadPNG(ImlibData * id, FILE * f, int *w, int *h, int *t)
+ {
+@@ -192,7 +198,7 @@
+ png_destroy_read_struct(&png_ptr, NULL, NULL);
+ return NULL;
+ }
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ return NULL;
@@ -1619,7 +1619,7 @@
return 0;
fread(buf, 1, 8, f);
diff --git a/graphics/imlib/files/patch-save.c b/graphics/imlib/files/patch-save.c
new file mode 100644
index 000000000000..88a23c0426c8
--- /dev/null
+++ b/graphics/imlib/files/patch-save.c
@@ -0,0 +1,11 @@
+--- Imlib/save.c.orig 2004-09-21 02:22:59.000000000 +0200
++++ Imlib/save.c 2012-04-27 07:19:57.000000000 +0200
+@@ -342,7 +342,7 @@
+ png_destroy_write_struct(&png_ptr, (png_infopp) NULL);
+ return 0;
+ }
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ fclose(f);
+ png_destroy_write_struct(&png_ptr, (png_infopp) NULL);
diff --git a/graphics/imlib/files/patch-utils.c b/graphics/imlib/files/patch-utils.c
new file mode 100644
index 000000000000..0d59d7879b1f
--- /dev/null
+++ b/graphics/imlib/files/patch-utils.c
@@ -0,0 +1,19 @@
+--- Imlib/utils.c.orig 2012-04-27 07:12:19.000000000 +0200
++++ Imlib/utils.c 2012-04-27 07:15:39.000000000 +0200
+@@ -1899,6 +1899,7 @@
+ };
+
+ #ifdef HAVE_LIBPNG
++#include "pngpriv.h"
+ static void
+ _png_io_read(png_structp png_ptr,
+ png_bytep data, png_uint_32 size)
+@@ -1982,7 +1983,7 @@
+ return NULL;
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ return NULL;