aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/imlib')
-rw-r--r--graphics/imlib/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index 1315e2f7de7e..f3e6988e8245 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -4,27 +4,27 @@
PORTNAME= imlib
PORTVERSION= 1.9.15
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A graphic library for enlightenment package
+COMMENT= Graphic library for enlightenment package
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- gif.5:${PORTSDIR}/graphics/giflib
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libgif.so:${PORTSDIR}/graphics/giflib
-USE_AUTOTOOLS= libtool
+# TODO: Remove :oldver together with version-info patching in pre-configure.
+USES= gmake libtool:oldver pathfix tar:bzip2
USE_XORG= sm xext x11
-USES= gmake tar:bzip2 pathfix
USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib --disable-modules
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+LDFLAGS+= -L${LOCALBASE}/lib
pre-configure:
@${REINPLACE_CMD} -e "s|10:15:9|5:0:0|" ${WRKSRC}/*/Makefile.in