aboutsummaryrefslogtreecommitdiff
path: root/graphics/iulib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/iulib/Makefile')
-rw-r--r--graphics/iulib/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/graphics/iulib/Makefile b/graphics/iulib/Makefile
index 5380bbc8aa79..bffd9395aac2 100644
--- a/graphics/iulib/Makefile
+++ b/graphics/iulib/Makefile
@@ -6,22 +6,23 @@
#
PORTNAME= iulib
-PORTVERSION= 0.3
+PORTVERSION= 0.4
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
+EXTRACT_SUFX= .tgz
MAINTAINER= hiroto.kagotani@gmail.com
COMMENT= A library of image understanding-related algorithms
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff
-WRKSRC= ${WRKDIR}/iulib
-
-OPTIONS= SDL "Enable SDL" off \
+OPTIONS= SDL "Enable SDL for graphical debugging" off \
VIDIO "Enable Video Input/Output (using ffmpeg)" off
MAKE_JOBS_SAFE= yes
+USE_PYTHON_BUILD= yes
USE_AUTOTOOLS= libtool:15 aclocal:110 automake:110 autoconf:262
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I${LOCALBASE}/share/aclocal
USE_LDCONFIG= yes
@@ -35,21 +36,16 @@ CONFIGURE_ARGS+=--without-SDL
USE_SDL= sdl
.endif
-.if !defined(WITH_VIDIO)
-PLIST_SUB+= VIDIO="@comment "
-.else
+.if defined(WITH_VIDIO)
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
-PLIST_SUB+= VIDIO=""
-.endif
-
+.else
post-patch:
- @${REINPLACE_CMD} -e '/tiff/s/^/#/' ${WRKSRC}/configure.ac
-.if !defined(WITH_VIDIO)
@${REINPLACE_CMD} -e 's/novidio, 0/novidio, 1/' ${WRKSRC}/configure.ac
.endif
pre-configure:
@(cd ${CONFIGURE_WRKSRC} \
+ && ${SETENV} ${PYTHON_CMD} genAM.py >Makefile.am \
&& ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} --automake)
run-autotools: run-autotools-aclocal run-autotools-automake run-autotools-autoconf