aboutsummaryrefslogtreecommitdiff
path: root/graphics/jasper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/jasper/Makefile')
-rw-r--r--graphics/jasper/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/jasper/Makefile b/graphics/jasper/Makefile
index 46bfe1b26531..c28952746a5e 100644
--- a/graphics/jasper/Makefile
+++ b/graphics/jasper/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= jasper
-PORTVERSION= 2.0.21
+PORTVERSION= 2.0.23
DISTVERSIONPREFIX= version-
CATEGORIES= graphics
@@ -16,7 +16,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= cmake jpeg localbase
-CMAKE_OFF= JAS_ENABLE_AUTOMATIC_DEPENDENCIES
+CMAKE_OFF= JAS_ENABLE_AUTOMATIC_DEPENDENCIES JAS_ENABLE_DOC
CMAKE_ON= JAS_ENABLE_LIBJPEG
USE_LDCONFIG= yes
@@ -29,9 +29,12 @@ OPTIONS_DEFINE= OPENGL DOCS
OPTIONS_DEFAULT=OPENGL
OPTIONS_SUB= yes
-DOCS_CMAKE_BOOL= JAS_ENABLE_DOC
OPENGL_CMAKE_BOOL= JAS_ENABLE_OPENGL
OPENGL_USE= GL=gl,glu,glut XORG=x11,xext,xi,xmu
OPENGL_USES= gl xorg
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/jasper.pdf ${WRKSRC}/doc/jpeg2000.pdf ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>