aboutsummaryrefslogtreecommitdiff
path: root/graphics/jbigkit/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/jbigkit/files/patch-Makefile')
-rw-r--r--graphics/jbigkit/files/patch-Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/jbigkit/files/patch-Makefile b/graphics/jbigkit/files/patch-Makefile
new file mode 100644
index 000000000000..08cec0f9f572
--- /dev/null
+++ b/graphics/jbigkit/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- ./Makefile.orig 2014-03-27 18:47:15.000000000 +0000
++++ ./Makefile 2014-06-21 22:53:57.000000000 +0000
+@@ -1,24 +1,22 @@
+ # Unix makefile for JBIG-KIT
+
+ # Select an ANSI/ISO C compiler here, GNU gcc is recommended
+-CC = gcc
++#CC = gcc
+
+ # Options for the compiler: A high optimization level is suggested
+-CFLAGS = -O2 -W -Wno-unused-result
++CFLAGS += -W # -Wno-unused-result -- older compilers don't have this
+ # CFLAGS = -O -g -W -Wall -Wno-unused-result -ansi -pedantic # -DDEBUG
+
+-export CC CFLAGS
+-
+ VERSION=2.1
+
+ all: lib pbm
+ @echo "Enter 'make test' in order to start some automatic tests."
+
+ lib:
+- cd libjbig && $(MAKE) -e
++ cd libjbig && $(MAKE)
+
+ pbm: lib
+- cd pbmtools && $(MAKE) -e
++ cd pbmtools && $(MAKE)
+
+ test: lib pbm
+ cd libjbig && $(MAKE) test