aboutsummaryrefslogtreecommitdiff
path: root/graphics/jpeg2ps-letter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/jpeg2ps-letter/Makefile')
-rw-r--r--graphics/jpeg2ps-letter/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/graphics/jpeg2ps-letter/Makefile b/graphics/jpeg2ps-letter/Makefile
index ef678228d72d..78876a1d4052 100644
--- a/graphics/jpeg2ps-letter/Makefile
+++ b/graphics/jpeg2ps-letter/Makefile
@@ -7,38 +7,35 @@
PORTNAME= jpeg2ps
PORTVERSION= 1.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics converters
MASTER_SITES= http://www.pdflib.com/products/more/jpeg2ps/
PKGNAMESUFFIX= -${PAPERSIZE}
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Converter for JPEG compressed images to PostScript Level 2
-PAPERSIZE?= letter
-
-INSTALL_TARGET=
+MAKE_ARGS+= CFLAGS="-c ${CFLAGS}" LD="${CC}"
-MAN1= jpeg2ps.1
+MAN1= jpeg2ps.1
+PLIST_FILES= bin/jpeg2ps
-PLIST_FILES= bin/jpeg2ps %%DOCSDIR%%/jpeg2ps.txt
-PLIST_DIRS= %%DOCSDIR%%
+PAPERSIZE?= letter
-.include <bsd.port.pre.mk>
+.if !defined(NOPORTDOCS)
+PORTDOCS= jpeg2ps.txt
+.endif
.if ${PAPERSIZE} == a4
-post-patch:
- ${CP} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.input
- ${SED} "s%CCFLAGS=-O -c%CCFLAGS=-O -c -DA4%" ${WRKSRC}/Makefile.input > ${WRKSRC}/Makefile
- ${RM} -f ${WRKSRC}/Makefile.input
+CFLAGS+= -DA4
.endif
-post-install:
+do-install:
${INSTALL_PROGRAM} ${WRKSRC}/jpeg2ps ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/jpeg2ps.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/jpeg2ps.txt ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/jpeg2ps.1 ${MANPREFIX}/man/man1
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>