aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdegraphics2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/kdegraphics2/Makefile')
-rw-r--r--graphics/kdegraphics2/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/graphics/kdegraphics2/Makefile b/graphics/kdegraphics2/Makefile
new file mode 100644
index 000000000000..3c8c4c2ca51c
--- /dev/null
+++ b/graphics/kdegraphics2/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: kdegraphics
+# Version required: Beta1
+# Date created: 28 October 1997
+# Whom: Stefan Eßer <se@freebsd.org>
+#
+# $Id:$
+#
+
+DISTNAME= kdegraphics-Beta3-1
+PKGNAME= kdegraphics-3.1b
+CATEGORIES= graphics kde
+MASTER_SITES= ftp://ftp.net.lut.ac.uk/kde/stable/Beta3/distribution/tgz/source/ \
+ ftp://ftp.uni-erlangen.de/pub/Linux/MIRROR.KDE/stable/Beta3/distribution/tgz/source/ \
+ ftp://ftp.caldera.com/pub/mirrors/kde/stable/Beta3/distribution/tgz/source/
+EXTRACT_SUFX= .src.tar.gz
+
+MAINTAINER= se@freebsd.org
+
+LIB_DEPENDS= qt\\.1\\.3[1-9]:${PORTSDIR}/x11/qt \
+ gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+ jpeg\\.[67]\\.:${PORTSDIR}/graphics/jpeg \
+ kdecore\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+ kdeui\\.0\\.9[1-9]:${PORTSDIR}/x11/kdelibs \
+ jscript\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+ khtmlw\\.0\\.9[1-9]:${PORTSDIR}/x11/kdelibs \
+ kfm\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+ mediatool\\.0\\.[6-9]:${PORTSDIR}/x11/kdelibs
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
+ "--with-extra-includes=$(PREFIX)/include/giflib"
+
+CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" \
+ INSTALL_SCRIPT="install -c -m 555"
+
+WRKSRC= ${WRKDIR}/kdegraphics
+USE_GMAKE= yes
+
+.include <bsd.port.mk>