aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdegraphics3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/kdegraphics3/Makefile')
-rw-r--r--graphics/kdegraphics3/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/graphics/kdegraphics3/Makefile b/graphics/kdegraphics3/Makefile
index 193b12e8e9e0..95e755a877a1 100644
--- a/graphics/kdegraphics3/Makefile
+++ b/graphics/kdegraphics3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdegraphics
-PORTVERSION= 2.1.1
+PORTVERSION= 2.2
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
@@ -22,4 +22,11 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+pre-configure:
+ ${PERL} -pi -e "s@libkscan_la_LIBADD =@libkscan_la_LIBADD= -lintl@g" ${WRKSRC}/libkscan/Makefile.in
+ ${PERL} -pi -e "s@libkcm_kamera_la_LIBADD =@libkcm_kamera_la_LIBADD= -lintl@g" ${WKRSRC}/kamera/kcontrol/Makefile.in
+ ${PERL} -pi -e "s@name = item@name=(char*)item@g" ${WRKSRC}/kamera/kcontrol/kamera.cpp
+ find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ "s@GPHOTO2_LIBS =@GPHOTO2_LIBS= -lintl@g"
+
.include <bsd.port.mk>