aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdegraphics3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/kdegraphics3/Makefile')
-rw-r--r--graphics/kdegraphics3/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/graphics/kdegraphics3/Makefile b/graphics/kdegraphics3/Makefile
index 5cd06a85e3bc..193b12e8e9e0 100644
--- a/graphics/kdegraphics3/Makefile
+++ b/graphics/kdegraphics3/Makefile
@@ -6,28 +6,20 @@
#
PORTNAME= kdegraphics
-PORTVERSION= 2.1
+PORTVERSION= 2.1.1
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2
BUILD_DEPENDS= dvips:${PORTSDIR}/print/teTeX
RUN_DEPENDS= dvips:${PORTSDIR}/print/teTeX
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc" \
- USER_LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
.include <bsd.port.mk>