aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdegraphics4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/kdegraphics4/Makefile')
-rw-r--r--graphics/kdegraphics4/Makefile100
1 files changed, 56 insertions, 44 deletions
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
index 14d8e796a302..6eda9980cb34 100644
--- a/graphics/kdegraphics4/Makefile
+++ b/graphics/kdegraphics4/Makefile
@@ -8,16 +8,19 @@
PORTNAME= kdegraphics
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 2
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Graphics utilities for the KDE3 integrated X11 desktop
-LIB_DEPENDS= fribidi:${PORTSDIR}/converters/fribidi \
+LIB_DEPENDS= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ freetype:${PORTSDIR}/print/freetype2 \
+ fribidi:${PORTSDIR}/converters/fribidi \
+ lcms:${PORTSDIR}/graphics/lcms \
glut:${PORTSDIR}/graphics/libglut
RUN_DEPENDS= pdfinfo:${PORTSDIR}/graphics/xpdf
@@ -33,69 +36,78 @@ WANT_GNOME= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+OPTIONS= IMLIB "Build Kuickshow, a fast and versatile image viewer" off \
+ GPHOTO2 "Enable support for digital cameras" off \
+ SANE "Build Kooka, a SANE scanner frontend for KDE" off
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-IMLIB_CONFIG= ${X11BASE}/bin/imlib-config
+.if exists (${X11BASE}/bin/imlib-config)
+. if !defined(WITH_IMLIB)
+IMLIB_OVERRIDE= yes
+WITH_IMLIB= yes
+. endif
+.endif
+
+.if exists(${LOCALBASE}/bin/gphoto2-config)
+. if !defined(WITH_GPHOTO2)
+GPHOTO2_OVERRIDE= yes
+WITH_GPHOTO2= yes
+. endif
+.endif
-.if exists(${IMLIB_CONFIG})
-WITH_IMLIB?= yes
+.if exists (${LOCALBASE}/bin/sane-config)
+. if !defined(WITH_SANE)
+SANE_OVERRIDE= yes
+WITH_SANE= yes
+. endif
.endif
-.if defined(WITH_IMLIB) || defined(KDE_WITH_IMLIB)
+.if defined(WITH_IMLIB)
USE_GNOME= imlib
PLIST_APPEND+= plist.imlib
CONFIGURE_ARGS+=--with-imlib-config=${X11BASE}/bin
.else
WITHOUT_IMLIB= yes
CONFIGURE_ARGS+=--without-imlib-config
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG} "If you want to compile with imlib support (enables"
- @${ECHO_MSG} "kuickshow), hit Ctrl-C right now and use"
- @${ECHO_MSG} "\"make WITH_IMLIB=yes\""
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG}
-.endif # defined(WITH_IMLIB) || defined(KDE_WITH_IMLIB)
-
-GPHOTO2_CONFIG= ${LOCALBASE}/bin/gphoto2-config
-
-.if exists(${GPHOTO2_CONFIG})
-WITH_GPHOTO2?= yes
-.endif # exists(${GPHOTO2_CONFIG})
+.endif
.if defined(WITH_GPHOTO2)
LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/gphoto2
PLIST_APPEND+= plist.gphoto2
-.else
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG} "If you want to compile with digital camera support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_GPHOTO2=yes\""
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG}
-.endif # defined(WITH_GPHOTO2)
-
-SANE_CONFIG= ${LOCALBASE}/bin/sane-config
-
-.if exists(${SANE_CONFIG})
-WITH_SANE?= yes
-.endif # exists(${SANE_CONFIG})
+.endif
.if defined(WITH_SANE)
LIB_DEPENDS+= sane.1:${PORTSDIR}/graphics/sane-backends
PLIST_APPEND+= plist.sane
-RUN_DEPENDS= ${LOCALBASE}/bin/gocr:${PORTSDIR}/graphics/gocr
-.else
+RUN_DEPENDS+= ${LOCALBASE}/bin/gocr:${PORTSDIR}/graphics/gocr
+.endif
+
pre-everything::
+.if defined(IMLIB_OVERRIDE)
@${ECHO_MSG}
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG} "If you want to compile with scanner (SANE) support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SANE=yes\""
- @${ECHO_MSG} "======================================================="
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG} "* imlib is installed but WITH_IMLIB is not set! *"
+ @${ECHO_MSG} "* WITH_IMLIB has been enabled automatically. *"
+ @${ECHO_MSG} "********************************************************"
@${ECHO_MSG}
-.endif # defined(WITH_SANE)
+.endif
+.if defined(GPHOTO2_OVERRIDE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG} "* gphoto2 is installed but WITH_GPHOTO2 is not set! *"
+ @${ECHO_MSG} "* WITH_GPHOTO2 has been enabled automatically. *"
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG}
+.endif
+.if defined(SANE_OVERRIDE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG} "* sane-backends is installed but WITH_SANE is not set! *"
+ @${ECHO_MSG} "* WITH_SANE has been enabled automatically. *"
+ @${ECHO_MSG} "********************************************************"
+ @${ECHO_MSG}
+.endif
.include <bsd.port.post.mk>