aboutsummaryrefslogtreecommitdiff
path: root/graphics/kipi-plugins-kde4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/kipi-plugins-kde4/Makefile')
-rw-r--r--graphics/kipi-plugins-kde4/Makefile124
1 files changed, 23 insertions, 101 deletions
diff --git a/graphics/kipi-plugins-kde4/Makefile b/graphics/kipi-plugins-kde4/Makefile
index 661f262263f8..65d6e38e85e5 100644
--- a/graphics/kipi-plugins-kde4/Makefile
+++ b/graphics/kipi-plugins-kde4/Makefile
@@ -1,122 +1,44 @@
-# New ports collection makefile for: kipi-plugins-kde4
-# Date created: Jan 23, 2009
-# Whom: Kris Moore
-#
# $FreeBSD$
-#
PORTNAME= kipi-plugins
PORTVERSION= ${DIGIKAM_VER}
-PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= graphics kde
+DISTFILES= #
MAINTAINER= kde@FreeBSD.org
-COMMENT= KDE4 kipi graphics plugins
-
-.include "${.CURDIR}/../digikam-kde4/Makefile.common"
-
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
- qjson:${PORTSDIR}/devel/qjson
-RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
+COMMENT= KDE 4 kipi graphics plugins (meta port)
LATEST_LINK= ${PORTNAME}-kde4
-OPTIONS_DEFINE= NLS EXPOBLEND GPOD KGEOMAP KSANE KVKONTAKTE MEDIAWIKI OPENCV PIMLIBS
-OPTIONS_DEFAULT= KGEOMAP KSANE OPENCV PIMLIBS
-NO_OPTIONS_SORT= yes
-
-EXPOBLEND_DESC= Add runtime deps for ExpoBlending plugin
-GPOD_DESC= Enable Ipod Export plugin
-KGEOMAP_DESC= Enable GPSSync (geolocalize pictures) plugin
-KSANE_DESC= Enable Scanning plugin
-KVKONTAKTE_DESC= Enable VKontakte (VK) plugin
-MEDIAWIKI_DESC= Enable MediaWiki plugin
-OPENCV_DESC= Enable Red Eye Removal plugin
-PIMLIBS_DESC= Enable Calendar plugins
-
-USE_PKGCONFIG= build
-USE_GL= glu
-USE_KDE4+= libkdcraw libkexiv2 libkipi
-
-CMAKE_ARGS= -DCMAKE_PREFIX_PATH:PATH=${KDE4_PREFIX}
+NO_BUILD= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.else
-CMAKE_ARGS+= -DWITH_NLS:BOOL=OFF
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MEXPOBLEND}
-RUN_DEPENDS+= align_image_stack:${PORTSDIR}/graphics/hugin
-.endif
-
-.if ${PORT_OPTIONS:MGPOD}
-LIB_DEPENDS+= gpod:${PORTSDIR}/audio/libgpod
-PLIST_SUB+= GPOD=""
-.else
-CMAKE_ARGS+= -DWITH_GLIB2:BOOL=OFF \
- -DWITH_GObject:BOOL=OFF \
- -DWITH_Gdk:BOOL=OFF \
- -DWITH_Ipod:BOOL=OFF
-PLIST_SUB+= GPOD="@comment "
-.endif
+.include "${.CURDIR}/../digikam-kde4/Makefile.common"
-.if ${PORT_OPTIONS:MKGEOMAP}
-LIB_DEPENDS+= kgeomap:${PORTSDIR}/astro/libkgeomap
-PLIST_SUB+= KGEOMAP=""
-.else
-CMAKE_ARGS+= -DWITH_KGeoMap:BOOL=OFF
-PLIST_SUB+= KGEOMAP="@comment "
-.endif
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-.if ${PORT_OPTIONS:MKSANE}
-USE_KDE4+= libksane
-PLIST_SUB+= KSANE=""
-.else
-CMAKE_ARGS+= -DWITH_KSane:BOOL=OFF
-PLIST_SUB+= KSANE="@comment "
-.endif
+# DOCS ans NLS options first, then plugins sorted in KIPI_PLUGINS_ALL
+NO_OPTIONS_SORT= yes
-.if ${PORT_OPTIONS:MKVKONTAKTE}
-LIB_DEPENDS+= kvkontakte:${PORTSDIR}/net/libkvkontakte
-PLIST_SUB+= KVKONTAKTE=""
-.else
-CMAKE_ARGS+= -DWITH_LibKVkontakte:BOOL=OFF
-PLIST_SUB+= KVKONTAKTE="@comment "
-.endif
+.for plugin in ${KIPI_PLUGINS_ALL}
+OPTIONS_DEFINE+= ${plugin:U}
+${plugin:U}_DESC= ${${plugin}_DESC}
+${plugin:U}_DEP= kipi-plugin-${plugin}>=${DIGIKAM_VER}:${PORTSDIR}/graphics/kipi-plugin-${plugin}
+.endfor
-.if ${PORT_OPTIONS:MMEDIAWIKI}
-LIB_DEPENDS+= mediawiki:${PORTSDIR}/net/libmediawiki
-PLIST_SUB+= MEDIAWIKI=""
-.else
-CMAKE_ARGS+= -DWITH_Mediawiki:BOOL=OFF
-PLIST_SUB+= MEDIAWIKI="@comment "
-.endif
+NLS_DEP= digikam-l10n>=${DIGIKAM_VER}:${PORTSDIR}/graphics/digikam-kde4-l10n
+DOCS_DEP= digikam-doc>=${DIGIKAM_VER}:${PORTSDIR}/graphics/digikam-kde4-doc
-.if ${PORT_OPTIONS:MOPENCV}
-LIB_DEPENDS+= opencv_legacy:${PORTSDIR}/graphics/opencv
-PLIST_SUB+= OPENCV=""
-.else
-CMAKE_ARGS+= -DWITH_OpenCV:BOOL=OFF
-PLIST_SUB+= OPENCV="@comment "
-.endif
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MPIMLIBS}
-USE_KDE4+= pimlibs
-PLIST_SUB+= PIMLIBS=""
-.else
-CMAKE_ARGS+= -DWITH_KdepimLibs:BOOL=OFF
-PLIST_SUB+= PIMLIBS="@comment "
-.endif
+.for opt in ${OPTIONS_DEFINE}
+. if ${PORT_OPTIONS:M${opt}}
+RUN_DEPENDS+= ${${opt}_DEP}
+. endif
+.endfor
-post-patch:
- ${LN} -s ../../doc ${WRKSRC}/doc
- ${LN} -s ../../po ${WRKSRC}/po
- ${RM} ${WRKSRC}/po/*/digikam.po ${WRKSRC}/po/*/libkgeomap.po
+do-install:
+ ${DO_NADA}
.include <bsd.port.mk>