aboutsummaryrefslogtreecommitdiff
path: root/graphics/libchamplain/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libchamplain/Makefile')
-rw-r--r--graphics/libchamplain/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/graphics/libchamplain/Makefile b/graphics/libchamplain/Makefile
index b4b99d94e7ba..7fc3bb64b8be 100644
--- a/graphics/libchamplain/Makefile
+++ b/graphics/libchamplain/Makefile
@@ -1,29 +1,29 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/graphics/libchamplain/Makefile,v 1.23 2010/09/27 18:17:23 kwm Exp $
+# $MCom: ports/trunk/graphics/libchamplain/Makefile 20031 2014-11-02 21:47:55Z kwm $
PORTNAME= libchamplain
-PORTVERSION= 0.8.1
-PORTREVISION= 7
+PORTVERSION= 0.12.9
CATEGORIES= graphics
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
-COMMENT= C library provides a Gtk+ widget to display rasterized maps/markers
+COMMENT= C library aimed to provide a Gtk+ widget to display rasterized maps and markers
-LIB_DEPENDS= libclutter-gtk-0.10.so:${PORTSDIR}/graphics/clutter-gtk \
+LIB_DEPENDS= libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3 \
libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome
-USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
-USE_GNOME= gnomeprefix gtk20 introspection:build,run
-USE_SQLITE= 3
+USES= gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gtk30 introspection:build
USE_GL= gl
+USE_SQLITE= 3
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgthread-2.0
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --enable-gtk-doc-html=no
INSTALL_TARGET= install-strip
-PLIST_SUB= VERSION=0.8
+PLIST_SUB= VERSION=0.12
.include <bsd.port.mk>