aboutsummaryrefslogtreecommitdiff
path: root/graphics/libjpeg-turbo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libjpeg-turbo/Makefile')
-rw-r--r--graphics/libjpeg-turbo/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index 3d5073607562..f91d387fecce 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -26,6 +26,8 @@ ALL_TARGET= test
MAN1= cjpeg.1 djpeg.1 jpegtran.1 rdjpgcom.1 wrjpgcom.1
PLIST_SUB= SOVERSION=${SOVERSION}
+PORTDOCS= *
+PORTEXAMPLES= *
# chase graphics/jpeg
SOVERSION= 11
@@ -38,4 +40,21 @@ OPTIONS+= PIC "Static library with PIC (required for VirtualGL)" off
CONFIGURE_ARGS+=--with-pic
.endif
+post-patch:
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e '/^install-data-am/s,install-dist_docDATA,,' \
+ ${WRKSRC}/Makefile.in
+.else
+ ${REINPLACE_CMD} -e '/^docdir/s,=.*,= ${DOCSDIR},' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.if defined(NOPORTEXAMPLES)
+ ${REINPLACE_CMD} -e '/^install-data-am/s,install-dist_exampleDATA,,' \
+ ${WRKSRC}/Makefile.in
+.else
+ ${REINPLACE_CMD} -e '/^exampledir/s,=.*,= ${EXAMPLESDIR},' \
+ ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>