aboutsummaryrefslogtreecommitdiff
path: root/graphics/libjpeg-turbo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libjpeg-turbo/Makefile')
-rw-r--r--graphics/libjpeg-turbo/Makefile57
1 files changed, 6 insertions, 51 deletions
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index 346294153e52..52bcaef07760 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -1,57 +1,12 @@
# Created by: Denis Podolskiy <bytestore@yandex.ru>
# $FreeBSD$
-PORTNAME= libjpeg-turbo
-PORTVERSION= 1.3.0
-PORTREVISION= 1
-CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+PKGNAMEPREFIX= lib
-MAINTAINER= bytestore@yandex.ru
-COMMENT= SIMD-accelerated JPEG codec which provides both the libjpeg,TurboJPEG
+COMMENT= SIMD-accelerated JPEG codec library, provides libTurboJPEG
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+MASTERDIR= ${.CURDIR:H}/jpeg-turbo
+SLAVE_PORT= yes
+OPTIONS_SLAVE= PIC
-CONFLICTS_INSTALL= jpeg-[0-9]*
-ONLY_FOR_ARCHS= amd64 i386
-USES= libtool
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= SO_MAJOR_VERSION=${SOVERSION}
-CONFIGURE_ARGS= --with-jpeg8
-USE_LDCONFIG= yes
-ALL_TARGET= test
-
-PLIST_SUB= SOVERSION=${SOVERSION}
-PORTDOCS= *
-PORTEXAMPLES= *
-
-# chase graphics/jpeg
-SOVERSION= 11
-
-OPTIONS_DEFINE= PIC DOCS EXAMPLES
-PIC_DESC= Static library with PIC (required for VirtualGL)
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPIC}
-CONFIGURE_ARGS+=--with-pic
-.endif
-
-post-patch:
-.if ! ${PORT_OPTIONS:MDOCS}
- ${REINPLACE_CMD} -e '/^install-data-am/s,install-dist_docDATA,,' \
- ${WRKSRC}/Makefile.in
-.else
- ${REINPLACE_CMD} -e '/^docdir/s,=.*,= ${DOCSDIR},' \
- ${WRKSRC}/Makefile.in
-.endif
-
-.if ! ${PORT_OPTIONS:MEXAMPLES}
- ${REINPLACE_CMD} -e '/^install-data-am/s,install-dist_exampleDATA,,' \
- ${WRKSRC}/Makefile.in
-.else
- ${REINPLACE_CMD} -e '/^exampledir/s,=.*,= ${EXAMPLESDIR},' \
- ${WRKSRC}/Makefile.in
-.endif
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"