aboutsummaryrefslogtreecommitdiff
path: root/graphics/libkexif/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libkexif/Makefile')
-rw-r--r--graphics/libkexif/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/graphics/libkexif/Makefile b/graphics/libkexif/Makefile
new file mode 100644
index 000000000000..e34a42504fdc
--- /dev/null
+++ b/graphics/libkexif/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libkexif
+# Date created: Mon Oct 18 19:41:36 CEST 2004
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= libkexif
+PORTVERSION= 0.1
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= digikam
+
+MAINTAINER= avleeuwen@piwebs.com
+COMMENT= Library for manipulating EXIF information embedded in images
+
+LIB_DEPENDS= exif.10:${PORTSDIR}/graphics/libexif
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+USE_GNOME= gnomehack pkgconfig
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>