aboutsummaryrefslogtreecommitdiff
path: root/graphics/libsixel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libsixel/Makefile')
-rw-r--r--graphics/libsixel/Makefile38
1 files changed, 34 insertions, 4 deletions
diff --git a/graphics/libsixel/Makefile b/graphics/libsixel/Makefile
index 5ed231607fc2..38bb1529ea02 100644
--- a/graphics/libsixel/Makefile
+++ b/graphics/libsixel/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= libsixel
-PORTVERSION= 20140422
+PORTVERSION= 0.19.5
+PORTEPOCH= 1
CATEGORIES= graphics
MAINTAINER= sue@iwmt.org
@@ -12,15 +13,44 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= saitoha
-GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 8bd21f7
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 200e4d9
+
+USE_LDCONFIG= yes
+USES= libtool
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig
+
+INSTALL_TARGET= install-strip
PORTDOCS= README.md
+OPTIONS_DEFINE= CURL GD PIXBUF
+OPTIONS_DEFAULT=
+
+CURL_DESC= libcurl support
+GD_DESC= gd support
+PIXBUF_DESC= gdk-pixbuf2 support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCURL}
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+=--with-libcurl
+.endif
+
+.if ${PORT_OPTIONS:MGD}
+LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd
+CONFIGURE_ARGS+=--with-gd
+.endif
+
+.if ${PORT_OPTIONS:MPIXBUF}
+LIB_DEPENDS+= libgdk_pixbuf-2.0.so:${PORTSDIR}/graphics/gdk-pixbuf2
+CONFIGURE_ARGS+=--with-gdk-pixbuf2
+.endif
+
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsixel.so.0
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}