aboutsummaryrefslogtreecommitdiff
path: root/graphics/libsvg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libsvg/Makefile')
-rw-r--r--graphics/libsvg/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/graphics/libsvg/Makefile b/graphics/libsvg/Makefile
new file mode 100644
index 000000000000..a2ed37816e1a
--- /dev/null
+++ b/graphics/libsvg/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: libsvg
+# Date created: 2004-10-06
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsvg
+PORTVERSION= 0.1.2
+CATEGORIES= graphics
+MASTER_SITES= http://cairographics.org/cairo/snapshots/
+
+MAINTAINER= ahze@ahze.net
+COMMENT= A parser for SVG content in files or buffers
+
+LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_LIBTOOL_VER=15
+USE_GNOME= libxml2 gnomehack gnometarget
+USE_ICONV= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+PLIST_FILES= include/svg.h \
+ lib/libsvg.a \
+ lib/libsvg.so \
+ lib/libsvg.so.1 \
+ libdata/pkgconfig/libsvg.pc
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' \
+ ${WRKSRC}/src/svg_ascii.h
+.endif
+
+.include <bsd.port.post.mk>