aboutsummaryrefslogtreecommitdiff
path: root/graphics/linplasma/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/linplasma/Makefile')
-rw-r--r--graphics/linplasma/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/linplasma/Makefile b/graphics/linplasma/Makefile
index 53a6813d43ce..266a422d9144 100644
--- a/graphics/linplasma/Makefile
+++ b/graphics/linplasma/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: linplasma
+# New ports collection makefile for: LinPlasma
# Date created: 2000-10-22
-# Whom: trevor
+# Whom: Trevor Johnson <trevor@FreeBSD.org>
#
# $FreeBSD$
#
@@ -26,6 +26,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
post-patch:
@${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s:PI:M_PI:g" ${WRKSRC}/linplasma.c
+ @${REINPLACE_CMD} -e \
+ "s:(int)palptr = (int:palptr = (unsigned char *:" \
+ ${WRKSRC}/linplasma.c
pre-install:
${ECHO_CMD} "bin/linplasma" > ${PLIST}