aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-sdl_image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/linux-sdl_image/Makefile')
-rw-r--r--graphics/linux-sdl_image/Makefile37
1 files changed, 7 insertions, 30 deletions
diff --git a/graphics/linux-sdl_image/Makefile b/graphics/linux-sdl_image/Makefile
index 0dcc77234a72..5efe067f5163 100644
--- a/graphics/linux-sdl_image/Makefile
+++ b/graphics/linux-sdl_image/Makefile
@@ -7,44 +7,21 @@
#
PORTNAME= sdl_image
-PORTVERSION= 1.2.4
+PORTVERSION= 1.2.5
CATEGORIES= graphics linux
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
-PKGNAMEPREFIX= linux-
-DISTNAME= SDL_image-${PORTVERSION}-1.${MACHINE_ARCH}
-EXTRACT_SUFX= .rpm
-EXTRACT_ONLY=
+DISTNAME= SDL_image-${PORTVERSION}-1
MAINTAINER= nivit@users.sourceforge.net
COMMENT= A simple library to load images as SDL interfaces (linux version)
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
-BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-
-USE_LINUX= yes
-USE_LINUX_PREFIX= yes
-LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
+USE_LINUX_RPM= yes
+INSTALL_SHLIB= yes
ONLY_FOR_ARCHS= i386 amd64
DIST_SUBDIR= rpm
-NO_BUILD= yes
-
-DBPATH= /var/lib/rpm
-RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
- --nodeps --replacepkgs
-.if defined(NOPORTDOCS)
-RPMFLAGS+= --excludedocs
-.endif
-RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-MACHINE_ARCH= i386
-.endif
-
-do-install:
- @${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
- @${LDCONFIG_LINUX}
+PLIST_SUB+= SDLIMVER=${PORTVERSION}
+MD5_FILE= ${PKGDIR}/distinfo
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>