aboutsummaryrefslogtreecommitdiff
path: root/graphics/luminance
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/luminance')
-rw-r--r--graphics/luminance/Makefile63
-rw-r--r--graphics/luminance/distinfo3
-rw-r--r--graphics/luminance/files/patch-project.pro28
-rw-r--r--graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp10
-rw-r--r--graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp10
-rw-r--r--graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp13
-rw-r--r--graphics/luminance/pkg-descr4
-rw-r--r--graphics/luminance/pkg-plist41
8 files changed, 0 insertions, 172 deletions
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
deleted file mode 100644
index e7dd67a75547..000000000000
--- a/graphics/luminance/Makefile
+++ /dev/null
@@ -1,63 +0,0 @@
-# New ports collection makefile for: qtpfsgui
-# Date created: 28 Jul 2007
-# Whom: Yinghong.Liu <relaxbsd@gmail.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= qtpfsgui
-PORTVERSION= 1.9.2
-PORTREVISION= 1
-CATEGORIES= graphics
-MASTER_SITES= SF
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A graphical user interface that provides a workflow for HDR imaging
-
-BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
-LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2 \
- jpeg:${PORTSDIR}/graphics/jpeg \
- IlmImf:${PORTSDIR}/graphics/OpenEXR \
- tiff:${PORTSDIR}/graphics/tiff \
- fftw3f:${PORTSDIR}/math/fftw3-float
-
-USE_QT_VER= 4
-QT_COMPONENTS= corelib gui imageformats \
- linguist_build moc_build qmake_build rcc_build uic_build
-ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
-INSTALL_TARGET= install_target install_menu install_icon install_i18n
-INSTALLS_ICONS= yes
-
-LRELEASE= ${QT_PREFIX}/bin/lrelease-qt4
-
-.if !defined(NOPORTOOCS)
-INSTALL_TARGET+=install_htmls
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e '/^QMAKE_CXXFLAGS/d ; \
- s|PREFIX =.*$$|PREFIX = ${PREFIX}|g' ${WRKSRC}/project.pro
-.for file in src/MainWindow/mainWindow.cpp \
- src/Preferences/preferencesDialog.cpp \
- src/TransplantExif/transplant.cpp
- @${REINPLACE_CMD} -e 's|/usr/local/share/qtpfsgui/|${DOCSDIR}/|g' \
- ${WRKSRC}/${file}
-.endfor
-
-do-configure:
- @${LRELEASE} ${WRKSRC}/project.pro
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
-
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/qtpfsgui
- ${INSTALL} -d ${PREFIX}/share/icons/hicolor/48x48/apps
- @${LN} -sf ${PREFIX}/share/pixmaps/qtpfsgui.png \
- ${PREFIX}/share/icons/hicolor/48x48/apps/qtpfsgui.png
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for doc_file in AUTHORS Changelog README TODO
- ${INSTALL_DATA} ${WRKSRC}/${doc_file} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/graphics/luminance/distinfo b/graphics/luminance/distinfo
deleted file mode 100644
index 5dab1867c1ab..000000000000
--- a/graphics/luminance/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (qtpfsgui-1.9.2.tar.gz) = 8a037c1dc75f04752dc36a59e7237fc4
-SHA256 (qtpfsgui-1.9.2.tar.gz) = 4462ec3ea8cf17db7b1ebe624d378bf4e239b80e0de2b2c6bbdf8c00cce16c8e
-SIZE (qtpfsgui-1.9.2.tar.gz) = 1181880
diff --git a/graphics/luminance/files/patch-project.pro b/graphics/luminance/files/patch-project.pro
deleted file mode 100644
index cb4d0d736df3..000000000000
--- a/graphics/luminance/files/patch-project.pro
+++ /dev/null
@@ -1,28 +0,0 @@
---- project.pro.orig 2008-02-16 11:43:24.000000000 +0100
-+++ project.pro 2008-03-17 17:18:14.000000000 +0100
-@@ -298,13 +298,13 @@
- menu.files = qtpfsgui.desktop
- menu.path = $${PREFIX}/share/applications
- icon.files = images/qtpfsgui.png
--icon.path = $${PREFIX}/share/icons/hicolor/48x48/apps
-+icon.path = $${PREFIX}/share/pixmaps
- htmls.files = html
--htmls.path = $${PREFIX}/share/qtpfsgui
-+htmls.path = $${PREFIX}/share/doc/qtpfsgui
- i18n.files = i18n/lang_de.qm i18n/lang_es.qm i18n/lang_it.qm i18n/lang_fr.qm i18n/lang_pl.qm i18n/lang_tr.qm i18n/lang_ru.qm i18n/lang_cs.qm
- i18n.path = $$I18NDIR
- docs.files = README LICENSE AUTHORS INSTALL Changelog
--docs.path = $${PREFIX}/share/qtpfsgui
-+docs.path = $${PREFIX}/share/doc/qtpfsgui
-
- INSTALLS += target menu icon htmls i18n docs
- message ( "" )
-@@ -320,7 +320,7 @@
- message ("qtpfsgui ==> $$target.path")
- message ("qtpfsgui.desktop ==> $$menu.path")
- message ("qtpfsgui.png ==> $$icon.path")
--message ("html and docs ==> $$htmls.path")
-+message ("html ==> $$docs.path")
- message ("i18n messages ==> $$i18n.path")
- message ("********************************************************************")
-
diff --git a/graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp b/graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp
deleted file mode 100644
index 3e8dec9913bb..000000000000
--- a/graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/HdrCreation/mtb_alignment.cpp.orig 2008-03-17 15:55:26.000000000 +0100
-+++ src/HdrCreation/mtb_alignment.cpp 2008-03-17 15:57:21.000000000 +0100
-@@ -27,6 +27,7 @@
- #include <cassert>
- #include <QVector>
- #include "mtb_alignment.h"
-+#include "../arch/freebsd/math.h"
-
- QImage* shiftQImage(const QImage *in, int dx, int dy)
- {
diff --git a/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp b/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp
deleted file mode 100644
index 288384e31068..000000000000
--- a/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/HdrCreation/HdrCreationManager.cpp.prig 2008-04-29 01:18:04.000000000 +0900
-+++ src/HdrCreation/HdrCreationManager.cpp 2008-07-02 03:26:00.000000000 +0900
-@@ -28,6 +28,7 @@
- #include "../Exif/exif_operations.h"
- #include "mtb_alignment.h"
- #include "../Threads/hdrInputLoader.h"
-+#include "../arch/freebsd/math.h"
-
- HdrCreationManager::HdrCreationManager() {
- qtpfsgui_options=QtpfsguiOptions::getInstance();
diff --git a/graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp b/graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp
deleted file mode 100644
index a15b211d9f5b..000000000000
--- a/graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/TM_operators/mantiuk06/contrast_domain.cpp.orig 2008-04-28 18:15:22.000000000 +0200
-+++ src/TM_operators/mantiuk06/contrast_domain.cpp 2008-07-04 12:49:16.000000000 +0200
-@@ -41,8 +41,8 @@
- #include <string.h>
- #include <math.h>
-
--#ifdef WIN32
--#define exp10f( x ) exp( x * log (10))
-+#if defined(WIN32) || defined(__FreeBSD__)
-+#define exp10f(x) exp( (x) * log (10))
- #endif
-
- #include "contrast_domain.h"
diff --git a/graphics/luminance/pkg-descr b/graphics/luminance/pkg-descr
deleted file mode 100644
index a0b6587f4ee9..000000000000
--- a/graphics/luminance/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Qtpfsgui is a graphical user interface (based on trolltech's Qt4)
-that provides a workflow for HDR imaging.
-
-WWW: http://qtpfsgui.sourceforge.net/
diff --git a/graphics/luminance/pkg-plist b/graphics/luminance/pkg-plist
deleted file mode 100644
index cd5a44385a09..000000000000
--- a/graphics/luminance/pkg-plist
+++ /dev/null
@@ -1,41 +0,0 @@
-bin/qtpfsgui
-share/applications/qtpfsgui.desktop
-share/pixmaps/qtpfsgui.png
-share/icons/hicolor/48x48/apps/qtpfsgui.png
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/Changelog
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%DOCSDIR%%/html/dcraw.html
-%%DOCSDIR%%/html/faq.html
-%%DOCSDIR%%/html/hints.html
-%%DOCSDIR%%/html/images/batch-1.jpg
-%%DOCSDIR%%/html/images/copy_exif.jpeg
-%%DOCSDIR%%/html/images/mainwin.jpeg
-%%DOCSDIR%%/html/images/projectiveTransformationDialog.jpeg
-%%DOCSDIR%%/html/images/raw_conversion.jpg
-%%DOCSDIR%%/html/images/resize.jpeg
-%%DOCSDIR%%/html/images/snap-qt4_4.jpeg
-%%DOCSDIR%%/html/images/snap-qt4_5.jpeg
-%%DOCSDIR%%/html/images/snap-qt4_6.jpeg
-%%DOCSDIR%%/html/images/tonemapdialog.jpeg
-%%DOCSDIR%%/html/index.html
-%%DOCSDIR%%/html/manual.html
-%%DATADIR%%/i18n/lang_cs.qm
-%%DATADIR%%/i18n/lang_de.qm
-%%DATADIR%%/i18n/lang_es.qm
-%%DATADIR%%/i18n/lang_fr.qm
-%%DATADIR%%/i18n/lang_it.qm
-%%DATADIR%%/i18n/lang_pl.qm
-%%DATADIR%%/i18n/lang_ru.qm
-%%DATADIR%%/i18n/lang_tr.qm
-@dirrm %%DATADIR%%/i18n
-@dirrm %%DATADIR%%
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-@dirrm %%DOCSDIR%%/html/images
-@dirrm %%DOCSDIR%%/html
-@dirrm %%DOCSDIR%%
-@dirrmtry share/applications