aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-gallium-vdpau/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/mesa-gallium-vdpau/Makefile')
-rw-r--r--graphics/mesa-gallium-vdpau/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/graphics/mesa-gallium-vdpau/Makefile b/graphics/mesa-gallium-vdpau/Makefile
new file mode 100644
index 000000000000..a80b4fd19377
--- /dev/null
+++ b/graphics/mesa-gallium-vdpau/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= mesa-gallium-vdpau
+PORTVERSION= ${MESAVERSION}
+CATEGORIES= graphics
+
+COMMENT= Mesa Gallium VDPAU drivers
+
+USES= xorg
+USE_XORG= xcb xfixes xrandr
+
+LIB_DEPENDS= libva.so:multimedia/libva \
+ libvdpau.so:multimedia/libvdpau \
+ libzstd.so:archivers/zstd
+BUILD_DEPENDS= wayland-protocols>=1.8:graphics/wayland-protocols
+
+.include <bsd.port.options.mk>
+.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
+
+ONLY_FOR_ARCHS= i386 amd64 aarch64 powerpc64
+ONLY_FOR_ARCHS_REASON= Used only by amd/radeon hardware
+
+MESON_ARGS+= -Ddri-drivers="" \
+ -Dgallium-drivers="r300,r600,radeonsi" \
+ -Dvulkan-drivers="" \
+ -Dgallium-va=disabled \
+ -Dgallium-omx=disabled \
+ -Dgallium-xa=disabled \
+ -Dgallium-opencl=disabled \
+ -Dgallium-xvmc=disabled \
+ -Dgallium-nine=false \
+ -Degl=disabled \
+ -Dgbm=disabled \
+ -Dgles2=disabled \
+ -Dglx=disabled \
+ -Dopengl=false \
+ -Dshared-glapi=disabled \
+ -Dosmesa=none
+
+LDFLAGS_i386= -Wl,-znotext
+
+MESON_ARGS+= -Dgallium-vdpau=enabled
+
+.include "${MASTERDIR}/Makefile.targets"
+.include <bsd.port.post.mk>