aboutsummaryrefslogtreecommitdiff
path: root/graphics/metacam
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/metacam')
-rw-r--r--graphics/metacam/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/graphics/metacam/Makefile b/graphics/metacam/Makefile
index e629d96cad07..ac792a538ab5 100644
--- a/graphics/metacam/Makefile
+++ b/graphics/metacam/Makefile
@@ -14,25 +14,24 @@ USES= gmake
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
-PLIST_FILES= bin/metacam
+PLIST_FILES= bin/metacam man/man1/metacam.1.gz
PORTDOCS= README.canon README.casio
-MAN1= metacam.1
ALL_TARGET= ${PORTNAME}
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif