aboutsummaryrefslogtreecommitdiff
path: root/graphics/metapixel
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/metapixel')
-rw-r--r--graphics/metapixel/Makefile2
-rw-r--r--graphics/metapixel/files/patch-Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/metapixel/Makefile b/graphics/metapixel/Makefile
index 6286be88a534..40fd41a2878e 100644
--- a/graphics/metapixel/Makefile
+++ b/graphics/metapixel/Makefile
@@ -16,7 +16,7 @@ COMMENT= A photomosaic generator
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- ungif.5:${PORTSDIR}/graphics/libungif
+ gif.5:${PORTSDIR}/graphics/giflib
USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I.
diff --git a/graphics/metapixel/files/patch-Makefile b/graphics/metapixel/files/patch-Makefile
index 0f6cc7a449bc..88f5bedae4ae 100644
--- a/graphics/metapixel/files/patch-Makefile
+++ b/graphics/metapixel/files/patch-Makefile
@@ -52,7 +52,7 @@
metapixel-imagesize : $(IMAGESIZE_OBJS) librwimg
- $(CC) $(LDOPTS) -o metapixel-imagesize $(IMAGESIZE_OBJS) rwimg/librwimg.a -lpng -ljpeg -lgif -lm -lz
-+ $(CC) $(LDOPTS) -o metapixel-imagesize $(IMAGESIZE_OBJS) rwimg/librwimg.a -lpng -ljpeg -lungif -lm -lz
++ $(CC) $(LDOPTS) -o metapixel-imagesize $(IMAGESIZE_OBJS) rwimg/librwimg.a -lpng -ljpeg -lgif -lm -lz
-zoom : zoom.c librwimg
- $(CC) -o zoom $(OPTIMIZE) $(PROFILE) $(MACOS_CCOPTS) -DTEST_ZOOM zoom.c $(MACOS_LDOPTS) rwimg/librwimg.a -lpng -ljpeg -lgif -lm -lz