aboutsummaryrefslogtreecommitdiff
path: root/graphics/multican
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/multican')
-rw-r--r--graphics/multican/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/multican/Makefile b/graphics/multican/Makefile
index 845f2fa6bf06..deceecd28d2f 100644
--- a/graphics/multican/Makefile
+++ b/graphics/multican/Makefile
@@ -15,6 +15,7 @@ COMMENT= Remote control utility for Canon DSLR cameras
LICENSE= GPLv2
+CFLAGS+= -fPIC
USE_LDCONFIG= yes
PLIST_FILES= bin/multican lib/libmultican.so.0 lib/libmultican.so \
@@ -25,7 +26,7 @@ PORTDOCS= ChangeLog README TODO
.if ${OSVERSION} < 800069
LIB_DEPENDS= usb:${PORTSDIR}/devel/libusb
-CFLAGS+= -I${LOCALBASE}/include -fPIC
+CFLAGS+= -I${LOCALBASE}/include # does not uphold CPPFLAGS
MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
.endif