aboutsummaryrefslogtreecommitdiff
path: root/graphics/ogre3d
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ogre3d')
-rw-r--r--graphics/ogre3d/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 3a97f6900726..79aca7cca335 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -23,11 +23,12 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
WRKSRC= ${WRKDIR}/ogre
CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static \
--with-cppunit-prefix=/nonexistent --disable-freeimage
-CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG" \
- ZZIPLIB_CFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV+= ZZIPLIB_CFLAGS="-I${LOCALBASE}/include" \
ZZIPLIB_LIBS="-L${LOCALBASE}/lib -lzzip"
-OPTIONS= GTK "Use GTK instead of Xt gui" off
+OPTIONS= GTK "Use GTK instead of Xt gui" off \
+ DEBUG "Enable debug mode" off \
+ DEMOS "Build OGRE demos" off
GNU_CONFIGURE= YES
USE_AUTOTOOLS= libtool:15
@@ -40,6 +41,19 @@ USE_XORG= xaw
.include <bsd.port.pre.mk>
+.if !defined(WITH_DEBUG)
+CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include"
+.endif
+
+.if defined(WITH_DEMOS)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
+RUN_DEPENDS+= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
+.else
+CONGIGURE_ARGS+= --disable-ogre-demos
+.endif
+
.if defined(WITH_GTK)
USE_GNOME+= gtk20
CONFIGURE_ARGS+=--with-gui=gtk