aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencv-core
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/opencv-core')
-rw-r--r--graphics/opencv-core/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/graphics/opencv-core/Makefile b/graphics/opencv-core/Makefile
index 50dd345f984d..f8c078f2d49a 100644
--- a/graphics/opencv-core/Makefile
+++ b/graphics/opencv-core/Makefile
@@ -4,4 +4,9 @@
_BUILDING_OPENCV_CORE= yes
MASTERDIR= ${.CURDIR}/../opencv
+_COMPVERSION!= ${CC} --version
+.if ${_COMPVERSION:Mclang}
+CXXFLAGS+= -std=gnu++11 -Wno-error -Wno-c++11-narrowing
+.endif
+
.include "${MASTERDIR}/Makefile"