aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/opendx/Makefile')
-rw-r--r--graphics/opendx/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index fc6bdef3c1a6..92994a03b929 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -13,13 +13,16 @@ MASTER_SITES= http://opendx.npaci.edu/source/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3
+LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3 \
+ netcdf.1:${PORTSDIR}/math/netcdf
USE_XLIB= yes
REQUIRES_MOTIF= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -Dfreebsd" \
- CXXFLAGS="${CFLAGS} -Dfreebsd"
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -Dfreebsd -I${PREFIX}/include" \
+ CPPFLAGS="-I${PREFIX}/include" \
+ CXXFLAGS="${CFLAGS} -Dfreebsd -I${PREFIX}/include" \
+ LDFLAGS="-L${PREFIX}/lib"
NO_MTREE= yes
PLIST_SUB= ARCH=${MACHINE_ARCH}