aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/opendx/Makefile')
-rw-r--r--graphics/opendx/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index 6620a8eee73d..fa10327c09df 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -22,7 +22,6 @@ USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
-CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV= ARCH=freebsd
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -75,8 +74,7 @@ post-patch:
@${FIND} ${WRKSRC}/${dir} -type f | ${XARGS} \
${REINPLACE_CMD} -e "s;/usr/lpp;${PREFIX};g"
.endfor
- @${REINPLACE_CMD} -e "s;-lpthread;${PTHREAD_LIBS};g" \
- -e "s;/usr/X11R6;${LOCALBASE};g" \
+ @${REINPLACE_CMD} -e "s;/usr/X11R6;${LOCALBASE};g" \
${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|startserver.bat||" \
${WRKSRC}/src/uipp/java/server/Makefile.in