aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/osg-devel/Makefile')
-rw-r--r--graphics/osg-devel/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 9b105652d27f..44a23af768b6 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -6,42 +6,48 @@
#
PORTNAME= osg
-PORTVERSION= 0.9.3
+PORTVERSION= 0.9.4.2
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/download/snapshots/
-DISTNAME= OpenSceneGraph-${PORTVERSION}
+DISTNAME= OpenSceneGraph-${PORTVERSION:R}-${PORTVERSION:E}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= C++ OpenGL scene graph library for real-time rendering
-BROKEN= "Does not compile"
-
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
ungif.5:${PORTSDIR}/graphics/libungif \
tiff.4:${PORTSDIR}/graphics/tiff \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ Producer.0:${PORTSDIR}/graphics/openproducer
+
+ONLY_FOR_ARCHS= i386
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_MESA= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-MAKE_ENV= OSGHOME=${WRKSRC}
+MAKE_ENV= OSGHOME=${WRKSRC} \
+ PTHREAD_LIBS=${PTHREAD_LIBS}
+MAKEFILE= GNUmakefile
+WRKSRC= ${WRKDIR}/OpenSceneGraph-${PORTVERSION:R}
# opt = optimized ($OPTF added); debug = debug ($DBGF added); opt is default
ALL_TARGET= opt
+.include <bsd.port.pre.mk>
+
post-patch:
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
-e "s|malloc\.h|stdlib.h|"
+ @${REINPLACE_CMD} -e 's,%%CXXFLAGS%%,${CXXFLAGS},g' \
+ ${WRKSRC}/Make/makedefs
post-install:
- ${LN} -sf ${DATADIR}/bin/sgv ${PREFIX}/bin
- ${LN} -sf ${DATADIR}/bin/osgconv ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>