aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg-devel
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/osg-devel')
-rw-r--r--graphics/osg-devel/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 4807480703b2..63e766b8d374 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= osg
PORTVERSION= 2.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-2.6/
DISTNAME= OpenSceneGraph-${PORTVERSION}
@@ -15,14 +15,15 @@ DISTNAME= OpenSceneGraph-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= C++ OpenGL scene graph library for real-time rendering
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
USE_ZIP= yes
USE_CMAKE= yes
USE_GL= gl glu
WANT_SDL= yes
-
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+USE_LDCONFIG= yes
OPTIONS= CURL "Support for cURL" off \
FREETYPE "Support for FreeType" on \