aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-CAD-Drawing/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/p5-CAD-Drawing/Makefile')
-rw-r--r--graphics/p5-CAD-Drawing/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/graphics/p5-CAD-Drawing/Makefile b/graphics/p5-CAD-Drawing/Makefile
index 57af5fb9bb3e..56fb3c9aed12 100644
--- a/graphics/p5-CAD-Drawing/Makefile
+++ b/graphics/p5-CAD-Drawing/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${SITE_PERL}/Math/Vec.pm:${PORTSDIR}/math/p5-Math-Vec \
${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
${SITE_PERL}/Stream/FileInputStream.pm:${PORTSDIR}/devel/p5-Stream \
${SITE_PERL}/Math/Geometry/Planar.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
MAN3= CAD::Drawing.3 \
CAD::Drawing::Calculate.3 \
@@ -38,4 +38,10 @@ MAN3= CAD::Drawing.3 \
PERL_MODBUILD= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>