aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Image-Info/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/p5-Image-Info/Makefile')
-rw-r--r--graphics/p5-Image-Info/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/graphics/p5-Image-Info/Makefile b/graphics/p5-Image-Info/Makefile
index e1fe31816ce8..5a90cc8f93a2 100644
--- a/graphics/p5-Image-Info/Makefile
+++ b/graphics/p5-Image-Info/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Image-Info
PORTVERSION= 1.30
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for getting image information
-RUN_DEPENDS= ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
+RUN_DEPENDS= ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
BUILD_DEPENDS= ${RUN_DEPENDS}
@@ -26,4 +26,11 @@ MAN3= Image::Info.3 Image::Info::BMP.3 Image::Info::SVG.3 \
Image::Info::TIFF.3 Image::Info::PPM.3 \
Image::Info::XBM.3 Image::Info::XPM.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>