aboutsummaryrefslogtreecommitdiff
path: root/graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt')
-rw-r--r--graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt27
1 files changed, 0 insertions, 27 deletions
diff --git a/graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt b/graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt
deleted file mode 100644
index 3c2ccd8c1287..000000000000
--- a/graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/libpicviz/CMakeLists.txt.orig 2008-10-27 14:39:31.000000000 +0300
-+++ src/libpicviz/CMakeLists.txt 2008-11-10 02:00:01.000000000 +0300
-@@ -1,7 +1,7 @@
- add_subdirectory(plugins)
- #add_subdirectory(bindings)
-
--include_directories(${picviz_SOURCE_DIR}/src/libpicviz/include ${picviz_SOURCE_DIR}/src/libpicviz/parser ${picviz_SOURCE_DIR}/src/libpicviz/props)
-+include_directories(${picviz_SOURCE_DIR}/src/libpicviz/include ${picviz_SOURCE_DIR}/src/libpicviz/parser ${picviz_SOURCE_DIR}/src/libpicviz/props ${PCRE_INCLUDE_DIR})
-
- #set(CMAKE_SHARED_LINKER_FLAGS "-lm -lfl -ly")
- configure_file(
-@@ -26,7 +26,7 @@
-
- set_target_properties(picviz PROPERTIES SOVERSION 1)
-
--target_link_libraries(picviz "-lm -ldl")
-+target_link_libraries(picviz "-lm")
-
- install(TARGETS picviz LIBRARY DESTINATION ${LIB_INSTALL_DIR})
- INSTALL(FILES
-@@ -55,5 +55,5 @@
- PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
-
- INSTALL(FILES ${picviz_BINARY_DIR}/src/libpicviz/picviz.pc
-- DESTINATION ${LIB_INSTALL_DIR}/pkgconfig/ )
-+ DESTINATION ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig/ )
-