aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixie
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/pixie')
-rw-r--r--graphics/pixie/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index dcc0f7aba726..fdc4971e68d9 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -44,6 +44,10 @@ SUB_LIST+= PORTNAME=${PORTNAME}
NOT_FOR_ARCHS= alpha
.endif
+.if ${OSVERSION} >= 600000 && ${ARCH} == "sparc64"
+BROKEN= "doesn't compile because of internal gcc failure"
+.endif
+
post-patch:
@${FIND} -X ${WRKSRC} -name '*.cpp' -or -name '*.h' | \
${XARGS} ${REINPLACE_CMD} -i '' -e 's|malloc\.h|stdlib\.h|g'