aboutsummaryrefslogtreecommitdiff
path: root/graphics/povray31
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/povray31')
-rw-r--r--graphics/povray31/Makefile4
-rw-r--r--graphics/povray31/files/patch-ab7
-rw-r--r--graphics/povray31/files/patch-png_pov.c104
3 files changed, 107 insertions, 8 deletions
diff --git a/graphics/povray31/Makefile b/graphics/povray31/Makefile
index e5df5ca1a88e..f09b32c40e44 100644
--- a/graphics/povray31/Makefile
+++ b/graphics/povray31/Makefile
@@ -7,7 +7,7 @@
PORTNAME= povray
PORTVERSION= 3.1g
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.povray.org/pub/povray/%SUBDIR%/ \
ftp://ftp.mirrorservice.org/sites/ftp.povray.org/pub/povray/%SUBDIR%/ \
@@ -19,7 +19,7 @@ DISTFILES= povuni_s.tgz povuni_d.tgz
MAINTAINER= bkoenig@alpha-tierchen.de
COMMENT= Persistence of Vision Ray Tracer
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
OPTIONS= X11 "X Window support" On
diff --git a/graphics/povray31/files/patch-ab b/graphics/povray31/files/patch-ab
index 1acc44a9241f..39187f94ab5f 100644
--- a/graphics/povray31/files/patch-ab
+++ b/graphics/povray31/files/patch-ab
@@ -1,5 +1,5 @@
---- source/unix/makefile.orig Mon Nov 22 09:12:37 1999
-+++ source/unix/makefile Sat Dec 2 03:42:45 2006
+--- source/unix/makefile.orig 1999-11-22 02:12:37.000000000 +0100
++++ source/unix/makefile 2012-05-06 19:41:21.000000000 +0200
@@ -53,7 +53,7 @@
#CFLAGS = -O6 -finline-functions -ffast-math -c -ansi -m386 -DCPU=586 -DCOMPILER_VER=\".`uname`.$(CC)\" -DPOV_LIB_DIR=\"$(POVLIBDIR)\" $(SRCINC) $(LIBPNGINC) $(ZLIBINC)
@@ -33,8 +33,9 @@
# Use -Llibdir -lXXX if you want to use shared libraries (if they are
# available). It doesn't matter if you only have libXXX.a libraries.
-PNGDIR = $(SRCDIR)/libpng
+-LIBPNGINC = -I$(PNGDIR)
+PNGDIR = $(PREFIX)/include
- LIBPNGINC = -I$(PNGDIR)
++LIBPNGINC = -I$(PNGDIR) -I${LOCALBASE}/include/libpng15
#LIBPNGLIB = $(PNGDIR)/libpng.a
-LIBPNGLIB = -L$(PNGDIR) -lpng
+LIBPNGLIB = -L$(PREFIX)/lib -lpng
diff --git a/graphics/povray31/files/patch-png_pov.c b/graphics/povray31/files/patch-png_pov.c
index 0bc4b332b20a..c830f27e02c4 100644
--- a/graphics/povray31/files/patch-png_pov.c
+++ b/graphics/povray31/files/patch-png_pov.c
@@ -1,6 +1,104 @@
--- source/png_pov.c.orig 1999-05-01 15:01:24.000000000 +0200
-+++ source/png_pov.c 2010-03-29 11:17:58.000000000 +0200
-@@ -1445,7 +1445,7 @@
++++ source/png_pov.c 2012-05-05 07:28:33.000000000 +0200
+@@ -53,6 +53,7 @@
+ #include "optout.h"
+ #include "png.h"
+ #include "png_pov.h"
++#include "pngpriv.h"
+
+
+
+@@ -227,7 +228,7 @@
+ if (png_get_error_ptr(png_ptr))
+ Error_Line("libpng: %s\n",msg);
+
+- longjmp(png_ptr->jmpbuf,1);
++ longjmp(png_jmpbuf(png_ptr),1);
+ }
+
+
+@@ -356,7 +357,7 @@
+ Error("Error allocating PNG data structures");
+ }
+
+- if (setjmp(o_png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(o_png_ptr)))
+ {
+ /* If we get here, we had a problem reading the file */
+ Status_Info("\n");
+@@ -397,7 +398,7 @@
+ Error("Error allocating PNG data structures");
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* If we get here, we had a problem writing the file */
+ Status_Info("\n");
+@@ -509,7 +510,7 @@
+ Error("Error allocating PNG data structures");
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* If we get here, we had a problem writing the file */
+ if (handle->buffer != NULL)
+@@ -628,7 +629,7 @@
+ case APPEND_MODE:
+
+ #if defined(PNG_WRITE_FLUSH_SUPPORTED)
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* If we get here, we had a problem writing the file */
+
+@@ -943,7 +944,7 @@
+ }
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* If we get here, we had a problem writing the file */
+ fclose(handle->file);
+@@ -996,7 +997,7 @@
+ {
+ register int col, j, step;
+
+- if (setjmp(o_png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(o_png_ptr)))
+ {
+ /* If we get here, we had a problem reading the file, which probably
+ * means that we have read all the available data, rather than a real
+@@ -1006,7 +1007,7 @@
+ return(0);
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* If we get here, we had a problem writing the new file */
+ Status_Info("\n");
+@@ -1139,7 +1140,7 @@
+ {
+ if (png_ptr != NULL)
+ {
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* If we get here, we had a problem writing the file */
+
+@@ -1391,7 +1392,7 @@
+ return; /* -hdf99- */
+ }
+
+- if (setjmp(r_png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(r_png_ptr)))
+ {
+ /* If we get here, we had a problem reading the file */
+
+@@ -1445,7 +1446,7 @@
if (r_info_ptr->valid & PNG_INFO_tRNS)
{
for (index = 0; index < r_info_ptr->num_trans; index++)
@@ -9,7 +107,7 @@
}
Image->data.map_lines = (unsigned char **)
-@@ -1479,7 +1479,7 @@
+@@ -1479,7 +1480,7 @@
if (r_info_ptr->valid & PNG_INFO_tRNS)
{
for (index = 0; index < r_info_ptr->num_trans; index++)