aboutsummaryrefslogtreecommitdiff
path: root/graphics/povray36/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/povray36/Makefile')
-rw-r--r--graphics/povray36/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/povray36/Makefile b/graphics/povray36/Makefile
index 2fab13fe4fab..5d7c66378e30 100644
--- a/graphics/povray36/Makefile
+++ b/graphics/povray36/Makefile
@@ -7,7 +7,7 @@
PORTNAME= povray
PORTVERSION= 3.6.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.povray.org/pub/povray/%SUBDIR%/ \
ftp://ftp.mirrorservice.org/sites/ftp.povray.org/pub/povray/%SUBDIR%/ \
@@ -21,7 +21,7 @@ COMMENT= Persistence of Vision Ray Tracer
.if defined(WITH_ICC)
BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
tiff:${PORTSDIR}/graphics/tiff \
jpeg:${PORTSDIR}/graphics/jpeg
@@ -54,6 +54,8 @@ CFLAGS= -O3 -tpp7 -axN -Vaxlib
CXXFLAGS= -O3 -tpp7 -axN -Vaxlib
.endif
+CFLAGS+= -I${LOCALBASE}/include/libpng15
+CXXFLAGS+= -I${LOCALBASE}/include/libpng15
CONFIGURE_ARGS= --x-includes="${LOCALBASE}/include" --includedir=${LOCALBASE} \
CXXFLAGS="${CXXFLAGS} -L${LOCALBASE}/lib" \
CFLAGS="${CFLAGS} -L${LOCALBASE}/lib" \