aboutsummaryrefslogtreecommitdiff
path: root/graphics/povray36
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/povray36')
-rw-r--r--graphics/povray36/Makefile10
-rw-r--r--graphics/povray36/files/patch-src::frame.h23
-rw-r--r--graphics/povray36/files/patch-src::optin.cpp11
3 files changed, 39 insertions, 5 deletions
diff --git a/graphics/povray36/Makefile b/graphics/povray36/Makefile
index 85db21581c17..247b55635100 100644
--- a/graphics/povray36/Makefile
+++ b/graphics/povray36/Makefile
@@ -36,11 +36,11 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
.if defined(WITH_OPTIMIZED_FLAGS)
-CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
-CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -Wno-multichar
-.if (${MACHINE_ARCH} == "i386")
-CFLAGS+= -mcpu=i686 -march=i686 -mfancy-math-387
-CXXFLAGS+= -mcpu=i686 -march=i686 -mfancy-math-387
+CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
+CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -Wno-multichar
+.if (${MACHINE_ARCH} == "i386" && !${MACHINE_ARCH} == "amd64" )
+CFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
+CXXFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
.endif # i386
.endif
diff --git a/graphics/povray36/files/patch-src::frame.h b/graphics/povray36/files/patch-src::frame.h
new file mode 100644
index 000000000000..c37f3c036b35
--- /dev/null
+++ b/graphics/povray36/files/patch-src::frame.h
@@ -0,0 +1,23 @@
+--- src/frame.h.orig Tue Jan 7 10:08:30 2003
++++ src/frame.h Sun Dec 28 23:37:04 2003
+@@ -44,12 +44,20 @@
+ class pov_istream_class;
+ class pov_ostream_class;
+
++#if defined(__LP64__)
++typedef unsigned int u_int32 ;
++#else
+ typedef unsigned long u_int32 ;
++#endif
+ typedef unsigned short u_int16 ;
+ typedef unsigned char u_int8 ;
+ typedef unsigned char byte ;
+
++#if defined(__LP64__)
++typedef signed int int32 ;
++#else
+ typedef signed long int32 ;
++#endif
+ typedef signed short int16 ;
+ typedef signed char int8 ;
+
diff --git a/graphics/povray36/files/patch-src::optin.cpp b/graphics/povray36/files/patch-src::optin.cpp
new file mode 100644
index 000000000000..861253a79145
--- /dev/null
+++ b/graphics/povray36/files/patch-src::optin.cpp
@@ -0,0 +1,11 @@
+--- src/optin.cpp.orig Sun Dec 28 23:43:15 2003
++++ src/optin.cpp Sun Dec 28 23:43:52 2003
+@@ -364,7 +364,7 @@
+
+ static bool matches(char *v1, char *v2);
+
+-POV_ISTREAM *Opts_Locate_File(char *filename, unsigned long stype, char *buffer, int err_flag, POVMSObjectPtr obj);
++POV_ISTREAM *Opts_Locate_File(char *filename, u_int32 stype, char *buffer, int err_flag, POVMSObjectPtr obj);
+
+
+ /*****************************************************************************