aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-cgkit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-cgkit/Makefile')
-rw-r--r--graphics/py-cgkit/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/py-cgkit/Makefile b/graphics/py-cgkit/Makefile
new file mode 100644
index 000000000000..e4efc2169108
--- /dev/null
+++ b/graphics/py-cgkit/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: cgkit
+# Date created: Apr 15, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cgkit
+PORTVERSION= 1.1.0
+CATEGORIES= graphics python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Python Computer Graphics Kit
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,iostream\.h,iostream," ${WRKSRC}/src/noisemodule.cpp
+
+.include <bsd.port.mk>