aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-graph-dot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-graph-dot/Makefile')
-rw-r--r--graphics/py-graph-dot/Makefile54
1 files changed, 9 insertions, 45 deletions
diff --git a/graphics/py-graph-dot/Makefile b/graphics/py-graph-dot/Makefile
index 051162d32686..7727e6171feb 100644
--- a/graphics/py-graph-dot/Makefile
+++ b/graphics/py-graph-dot/Makefile
@@ -5,60 +5,24 @@
# $FreeBSD$
#
-PORTNAME= graph
-PORTVERSION= 1.6.1
-PORTREVISION= 2
+PORTNAME= graph-dot
+PORTVERSION= 1.7.0
CATEGORIES= graphics python
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= python-graph-${PORTVERSION}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
MAINTAINER= yzlin@FreeBSD.org
-COMMENT= A library for working with graphs in Python
+COMMENT= A library for working with graphs in Python, dot module
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pydot>=0:${PORTSDIR}/graphics/py-pydot
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pydot>=0:${PORTSDIR}/graphics/py-pydot \
+ ${PYTHON_PKGNAMEPREFIX}graph-core>=${PORTVERSION}:${PORTSDIR}/graphics/py-graph-core
PROJECTHOST= python-graph
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
-PYDISTUTILS_PKGNAME= python_graph
+PYDISTUTILS_PKGNAME= python_graph_dot
-USE_BZIP2= yes
-
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-
-TESTFILES= unittests-accessibility.py \
- unittests-cycles.py \
- unittests-digraph.py \
- unittests-filters.py \
- unittests-graph.py \
- unittests-heuristics.py \
- unittests-readwrite.py \
- unittests-searching.py \
- unittests-sorting.py \
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for f in COPYING Changelog README
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
-
-# This target is only meant to be used by the port maintainer.
-x-regression-test: install
-.for f in ${TESTFILES}
- @${ECHO} "" >> ${WRKSRC}/tests/${f}
- @${ECHO} "if __name__ == '__main__':" >> ${WRKSRC}/tests/${f}
- @${ECHO} " unittest.main()" >> ${WRKSRC}/tests/${f}
- @${ECHO} "Unit-testing ${f}..."
- @(cd ${WRKSRC}/tests && ${PYTHON_CMD} ${f})
-.endfor
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>