aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-h3
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-h3')
-rw-r--r--graphics/py-h3/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/graphics/py-h3/Makefile b/graphics/py-h3/Makefile
index 9d9b50664d7e..d592b88d0344 100644
--- a/graphics/py-h3/Makefile
+++ b/graphics/py-h3/Makefile
@@ -18,6 +18,8 @@ BUILD_DEPENDS= cmake:devel/cmake \
ninja:devel/ninja \
${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR}
LIB_DEPENDS= libh3.so:graphics/h3
+TEST_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
USES= localbase:ldflags python
USE_PYTHON= autoplist concurrent cython distutils
@@ -30,4 +32,7 @@ NUMPY_DESC= NumPy support
NUMPY_RUN_DEPENDS= ${PYNUMPY}
+do-test:
+ cd ${WRKSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} ${PYTHON_CMD} -m pytest -rs -v
+
.include <bsd.port.mk>