aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-opengl/files/patch-ab
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-opengl/files/patch-ab')
-rw-r--r--graphics/py-opengl/files/patch-ab14
1 files changed, 7 insertions, 7 deletions
diff --git a/graphics/py-opengl/files/patch-ab b/graphics/py-opengl/files/patch-ab
index 8b2e1a9a829a..ba09ad72c8a6 100644
--- a/graphics/py-opengl/files/patch-ab
+++ b/graphics/py-opengl/files/patch-ab
@@ -1,13 +1,13 @@
---- setup.py 2000/12/04 14:04:20 1.1
-+++ setup.py 2000/12/04 14:05:08
-@@ -80,8 +80,8 @@
+--- config.py 2000/12/18 16:41:01 1.1
++++ config.py 2000/12/18 16:42:29
+@@ -97,8 +97,8 @@
gl_libs = ["GL","X11","Xext"] # some Mesa versions need X11 here
- glu_libs = ["GLU","Xext","X11"] + gl_libs
+ glu_libs = ["GLU"] + gl_libs
glut_libs = ["glut","Xi","Xmu"] + glu_libs # + ['cvt'] SGI IRIX6
- include_dirs = ["src","/usr/local/include","/usr/X11/include","/usr/include"]
- gl_lib_dirs = ["/usr/local/lib","/usr/X11/lib","/usr/lib"]
+ include_dirs = ["src","%%LOCALBASE%%/include","%%X11BASE%%/include","/usr/include"]
+ gl_lib_dirs = ["%%LOCALBASE%%/lib","%%X11BASE%%/lib","/usr/lib"]
- glu_lib_dirs = gl_lib_dirs
- glut_lib_dirs = glu_lib_dirs
- wgl_extension = []
+ # special case for IRIX #########
+ # you may have to specify your own paths here
+ if sys.platform[0:4] == "irix": gl_lib_dirs = []