aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-qt4-svg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-qt4-svg/Makefile')
-rw-r--r--graphics/py-qt4-svg/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/graphics/py-qt4-svg/Makefile b/graphics/py-qt4-svg/Makefile
index ec8870594f16..d4f6b9cebfa5 100644
--- a/graphics/py-qt4-svg/Makefile
+++ b/graphics/py-qt4-svg/Makefile
@@ -8,11 +8,11 @@ CATEGORIES= graphics devel python
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtSvg module
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
-RUN_DEPENDS= ${PKGNAMEPREFIX}gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-qt4-gui
-
CONFIGURE_ARGS= --enable QtSvg
-PYQT4_DIST= yes
+PYQT_DIST= yes
+
+USES= python pyqt:4
+USE_PYQT= sip_build gui_run
USE_QT4= moc_build svg qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -25,5 +25,4 @@ API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
DEBUG_CONFIGURE_ON= --debug --trace
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
.include <bsd.port.mk>