aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-soya3d/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-soya3d/Makefile')
-rw-r--r--graphics/py-soya3d/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index 9ff7efa073e0..e920502a029e 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -31,6 +31,7 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_GL= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
MANDIR= ${WRKDIR}/${DISTNAME}/manpage/man1
MAN1= soya_editor.1
@@ -46,6 +47,10 @@ DISTFILES+= SoyaTutorial-${PORTVERSION}${EXTRACT_SUFX}
BROKEN= "Does not compile in ${ARCH}"
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/setup.py
+
post-install:
@${INSTALL_DIR} ${EXAMPLESDIR}
@${CP} -R ${WRKDIR}/SoyaTutorial-${PORTVERSION}/tutorial/* ${EXAMPLESDIR}