aboutsummaryrefslogtreecommitdiff
path: root/graphics/qcread/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qcread/Makefile')
-rw-r--r--graphics/qcread/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/qcread/Makefile b/graphics/qcread/Makefile
index 69f337befd23..f2be0782f6ce 100644
--- a/graphics/qcread/Makefile
+++ b/graphics/qcread/Makefile
@@ -20,8 +20,10 @@ post-extract:
@${CP} -r ${WRKSRC}/gnu-getopt/. ${WRKSRC}
do-install:
-
- ${INSTALL} ${COPY} -o root -g wheel -m 644 ${WRKSRC}/qcam.conf ${PREFIX}/etc
+ ${INSTALL} ${COPY} -o root -g wheel -m 644 ${WRKSRC}/qcam.conf ${PREFIX}/etc/qcam.conf.dist
+ if [ ! -e ${PREFIX}/etc/qcam.conf ]; then \
+ ${CP} ${PREFIX}/etc/qcam.conf.dist ${PREFIX}/etc/qcam.conf; \
+ fi
${INSTALL_PROGRAM} ${WRKSRC}/qcread ${PREFIX}/bin
.include <bsd.port.mk>