aboutsummaryrefslogtreecommitdiff
path: root/graphics/qt4-imageformats/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qt4-imageformats/Makefile')
-rw-r--r--graphics/qt4-imageformats/Makefile30
1 files changed, 10 insertions, 20 deletions
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index 0fd8f096b6a8..0598124b8063 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= imageformats
-PORTVERSION= 4.2.3
-PORTREVISION= 1
+PORTVERSION= ${QT4_VERSION}
+PORTREVISION=0
CATEGORIES?= graphics
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -18,28 +18,18 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt imageformat plugins for GIF, JPEG, MNG and SVG
-BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
- qmake-qt4:${PORTSDIR}/devel/qmake4 \
- rcc:${PORTSDIR}/devel/qt4-rcc
-LIB_DEPENDS= QtCore:${PORTSDIR}/devel/qt4-corelib \
- QtGui:${PORTSDIR}/x11-toolkits/qt4-gui \
- QtSvg:${PORTSDIR}/graphics/qt4-svg \
- QtXml:${PORTSDIR}/textproc/qt4-xml \
- jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ mng:${PORTSDIR}/graphics/libmng \
+ png:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff
-CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
- qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
- xfmail-1.5.5_[1-2]
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc rcc corelib gui svg xml
+QT_NONSTANDARD= yes
+QT_DIST= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= -fast -no-exceptions \
- -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
- -qt-gif -release -system-libjpeg -system-libpng \
- -system-zlib -prefix ${PREFIX} \
- -plugindir ${PREFIX}/lib/plugins -bindir ${PREFIX}/bin \
- -confirm-license
-
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \