aboutsummaryrefslogtreecommitdiff
path: root/graphics/qt4-imageformats/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qt4-imageformats/Makefile')
-rw-r--r--graphics/qt4-imageformats/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index f473fe8345cc..1641fbd10e16 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -18,6 +18,8 @@ USE_QT4= qmake_build moc_build rcc_build corelib gui svg xml
QT_NONSTANDARD= yes
QT_DIST= yes
+USES= pkgconfig
+
HAS_CONFIGURE= yes
ALL_TARGET= first
@@ -40,9 +42,8 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-NO_STAGE= yes
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake